Welcome Guest Search | Active Topics | Members | Log In | Register

My Movies - Alternative to Windows Media Center Options · View
jkwaterman
Posted: Monday, November 06, 2017 5:30:46 AM
Groups: Member

Joined: 2/25/2010
Posts: 178

Rank:
Rank based on contribution points and purchased points. Click to see details. (2726)
pauven wrote:
palmore wrote:
A bit more detail on this.

It appears Plex wants to sort or join movies together that have the same IMDB code, thus if I have a DVD version of Independance Day and a BluRay version, it makes these 1 movie.
Emby takes each file (from what I can tell thus far) and makes that a movie. (I.e. a work out collection I have is listed as 1 title in mymovies with several discs in it) and Emby treats each disk in that pack as individual listings/movies.

Thus MyMovies shows - 4842 titles
Plex shows - 4706 titles (I have several dupes and other things like personally added movies that have an IMDB of 000000, Plex joins these)
Emby shows - 4879

Again this is due to how each (Plex and Emby) import the data MyMovies spits out. Plex combines anything with the same IMDB key, and Emby makes a "movie/title" for each item with an nfo file (multi part disks etc)

Just figured I'd share my experiences thus far with MyMovies as my "golden" meta data app for all my other services.


I just wanted to share that I took this comment to heart when I programmed MM Browser. I wanted it to be a true 1:1 representation of the data in My Movies. Though it was tricky to program, I believe I have successfully accomplished this. For those giving MM Browser a workout, let me know if you see issues related to missing or combining titles.

I am aware of a few scenarios where the relationship will not be 1:1, as follows:

1) When you add new titles to your storage, but My Movies folder monitoring hasn't picked it up yet, MM Browser can still find and show them. Obviously, the artwork and information will be missing, but the title will be shown (folder name) with a blank cover, and MM Browser can still mount and play the ISO. Once My Movies finds the title, the next Sync in MM Browser will update the info. I find this helpful, as often I want to watch a new movie the same day I add it to my server, and sometimes My Movies is slow to pick it up.

2) When you add new titles to My Movies, but have yet to run a Sync in MM Browser, those changes will not be reflected in MM Browser. This is because the movie data is stored in a local DB for MM Browser (which makes it super fast) - you must run a Sync to get the My Movies data synced into MM Browser. This is virtually the same as Plex/Kodi.

3) When the title is not an ISO rip. For version 1 of MM Browser, I designed it around playing ISO rips, as that seems to be where the biggest solution gap exists, and of course also represents 100% of my collection. If you have non ISO titles in your collection, I have no idea what MM Browser will show, though I'm fairly certain it won't know how to play them even if it shows them. I'm very curious on this one, so please share feedback if you have non-ISO titles in your collection. I'm interested in adding non-ISO support, but will need input how this should work. I don't have a single non-ISO title in my whole collection, so I don't know how to even test this.

4) Box Sets. I have one Box Set in my collection, and it doesn't appear in MM Browser. Titles with multiple discs are fine (and you get prompted which disc to mount/play), but Box Sets are not working yet. I haven't figured out the requirements to make Box Sets show up.

Paul



How come this app phones back to your web page??

This doesn't appear to work. I downloaded the application after making sure I had all the prereqs. After unzipping the zip I copied the folder to the top level C:. I clicked on MMBrowser.exe and a blank screen appeared. No menu. Just a gear icon on the top left and an x icon the top left. Neither icon works. Also I have both blurays and dvds. For bluray I have standard ISOs and DVDs standard folders. Are you stating the the DVDs must be ISOs too? If so this is a nonstarter because it would be a lengthy task to convert all my dvd folders to ISO. Again, it is my understanding that folders are MyMovies standard for DVDs.
pauven
Posted: Monday, November 06, 2017 2:02:43 PM
Groups: Member

Joined: 5/13/2009
Posts: 114
Location: Georgia, USA

Rank:
Rank based on contribution points and purchased points. Click to see details. (76)
jkwaterman wrote:
How come this app phones back to your web page??


MM Browser is checking for updates (fyi, I just released v1.1 yesterday). When MM Browser finds that an update is available, it will present the Change Log to you to review, and you can click Cancel to skip, or click OK and MM Browser will auto-update. I hate apps that simply inform me an update is available and then make me do all the work to install it. The auto-update process simply downloads the same .zip file from the website that you would manually download, unzips it into the program directory, and restarts MM Browser. Depending upon your internet speed, this should take about a minute.

Has anyone experienced the auto-update feature yet? If so, please share your experience.

Update checking is a purely optional feature for your convenience. If you block it, MM Browser will still run just fine, and won't even complain (at least it shouldn't, if it does complain then that's a bug, so let me know).


jkwaterman wrote:
This doesn't appear to work. I downloaded the application after making sure I had all the prereqs. After unzipping the zip I copied the folder to the top level C:. I clicked on MMBrowser.exe and a blank screen appeared. No menu. Just a gear icon on the top left and an x icon the top left. Neither icon works.


That is an excellent question, and my apologies for not making this clear in the instructions. MM Browser was designed to be used with a remote control - as such, the mouse cannot be used to click on the GUI. There's a couple areas where you would still use a mouse (i.e. file/folder selection windows), but 99% of the GUI cannot use a mouse by design.

If you don't have a remote handy, use your keyboard. You can use the arrow keys to move around, Enter/Return to select, <-- Backspace to go back, and Escape to toggle a title as Watched/Unwatched. If your keyboard has a Play button, it should work to mount/play ISOs directly from the main page, otherwise you can Enter a title to see the FanArt details page, and select Play from there.


jkwaterman wrote:
Also I have both blurays and dvds. For bluray I have standard ISOs and DVDs standard folders. Are you stating the the DVDs must be ISOs too? If so this is a nonstarter because it would be a lengthy task to convert all my dvd folders to ISO. Again, it is my understanding that folders are MyMovies standard for DVDs.


For the current version, yes it must be ISO, but I want to add folder support and need your help. I've never don't a DVD folder, and don't know how it works. Can you give me some guidance?

How do you make a DVD folder?

What program plays back your DVD folders?

You're right that this is My Movies standard, but unfortunately it is a feature of My Movies I have never used. I have only used My Movies for cataloging my ISO Blu-Ray/DVD collection, which is 99% movies. For everything that is not an ISO movie, I will need help from the community to tell me what features they need, and how I can replicate their use case so I can program MM Browser to handle them.

Thanks for your help,
Paul

MM Browser is now Chameleon MediaCenter v2.2 - Finally for My Movies, a MCE replacement for Windows 10, plus a Music Library!
jkwaterman
Posted: Monday, November 06, 2017 7:48:20 PM
Groups: Member

Joined: 2/25/2010
Posts: 178

Rank:
Rank based on contribution points and purchased points. Click to see details. (2726)

How do you make a DVD folder?


Go into mymovies computer management. click collection. Copy bluray or dvd. destination type folder structure. Mymovies will default to folder structure for dvds and ISO file for blurays. You can of course choose to override that if you want.

after you use mymovies to rip the disk you will notice by going into disks, it will say "location type" online folder, not online file. This is a mymovies standard for all dvds and blurays. I think you're using online file which is why none of my disks are showing in your browser. I have 3000 disks in my collection and none are showing up. Also you are not suppose to map drives in mymovies.

What program plays back your DVD folders?


The dvds like bluray disks mounts virtual clone drive and brings it up in powerdvd. I have powerdvd 16

question how are we suppose to sync our collection in the mmbrowser?? I see no menu structure. You should let the user use a keyboard as well as a remote. I do all my testing on a regular PC "server". Not my HTPC client.



pauven
Posted: Monday, November 06, 2017 8:17:54 PM
Groups: Member

Joined: 5/13/2009
Posts: 114
Location: Georgia, USA

Rank:
Rank based on contribution points and purchased points. Click to see details. (76)
jkwaterman wrote:

How do you make a DVD folder?


Go into mymovies computer management. click collection. Copy bluray or dvd. destination type folder structure. Mymovies will default to folder structure for dvds and ISO file for blurays. You can of course choose to override that if you want.

after you use mymovies to rip the disk you will notice by going into disks, it will say "location type" online folder, not online file. This is a mymovies standard for all dvds and blurays. I think you're using online file which is why none of my disks are showing in your browser. I have 3000 disks in my collection and none are showing up. Also you are not suppose to map drives in mymovies.

Wow, I have literally never done this, and I've been using My Movies for 10+ years. Is My Movies acting as a front-end for AnyDVD*? I rip everything to ISO outside of My Movies, and use My Movies Folder Monitoring to discover the titles on my server.


jkwaterman wrote:

What program plays back your DVD folders?


The dvds like bluray disks mounts virtual clone drive and brings it up in powerdvd. I have powerdvd 16

I'm a bit confused on this one. I didn't realize that Virtual CloneDrive could mount folders. Or is there something extra going on here, like perhaps My Movies wrapping a folder as a ISO for VCD to mount?


jkwaterman wrote:

question how are we suppose to sync our collection in the mmbrowser?? I see no menu structure. You should let the user use a keyboard as well as a remote. I do all my testing on a regular PC "server". Not my HTPC client.

1) When you first start MM Browser, you will be presented with just the Gear (settings icon) and the X (exit icon). The Gear is the menu for which you are looking.

2) Yes, you can use your keyboard. Use the Arrow Keys to navigate, and Enter/Return to select. <- Backspace to go back, and Esc to toggle a movie between Watched/Unwatched. If your keyboard has a Play button, you can use that to mount/play an ISO from the covers screen, otherwise you would have to select a title to open the FanArt details page, and select Play from there.

3) On the settings screen, the first thing you need to do is identify the folders to scan. I have 3 folders, \\server\DVDs, \\server\Blu-Rays, and \\server\TV-Series.

4) At this point, you should be far enough along to 'Save' these settings, at which point a new icon will show up, the Sync icon.

5) Run a Sync, and when it is done you will see all your titles (well, at least the Blu-Rays that have ISOs, not sure about your DVDs).


With a collection as large as your collection, you will probably want to enable a couple options on the settings page for better performance.

1) Create a Local DB of Titles - Without this set, MM Browser will have to re-Sync every time you open it.

2) Cache Artwork in Program Directory - Without this set, MM Browser will pull your movie cover art from the folders (probably on your server, right?). With this enabled, a copy of your cover artwork will be stored in the MM Browser program directory - just make sure you have at least 1GB per 1000 titles available on your drive. For your 3k titles, you need about 3GB of storage space. Try it both ways to see if you like this feature, but I'm fairly certain you will want it enabled.

Thanks for your feedback. I'll give your directions a try.

Paul

MM Browser is now Chameleon MediaCenter v2.2 - Finally for My Movies, a MCE replacement for Windows 10, plus a Music Library!

* Installing and/or using AnyDVD is illegal in some countries. Users are themselves responsible for complying with local law when installing and using AnyDVD.

pauven
Posted: Monday, November 06, 2017 8:25:59 PM
Groups: Member

Joined: 5/13/2009
Posts: 114
Location: Georgia, USA

Rank:
Rank based on contribution points and purchased points. Click to see details. (76)
One last tip for using a keyboard (or remote) with MM Browser - since you said you are using your regular PC. I use my regular PC for 99% of my My Movies/MM Browser use, and I have 3 monitors. If I launch MM Browser, and then click on another program in another monitor, MM Browser loses focus, and keyboard inputs go to whatever other program I've selected.

Basically, make sure that you click on MM Browser so it has focus to receive keyboard presses (and most remote control button presses, which are handled as keyboard presses, though the media keys are special).

This is probably not an issue for single monitor setups, or typical HTPC's.

Paul

MM Browser is now Chameleon MediaCenter v2.2 - Finally for My Movies, a MCE replacement for Windows 10, plus a Music Library!
jkwaterman
Posted: Monday, November 06, 2017 10:16:25 PM
Groups: Member

Joined: 2/25/2010
Posts: 178

Rank:
Rank based on contribution points and purchased points. Click to see details. (2726)

Wow, I have literally never done this, and I've been using My Movies for 10+ years. Is My Movies acting as a front-end for AnyDVD*? I rip everything to ISO outside of My Movies, and use My Movies Folder Monitoring to discover the titles on my server.

Yes mymovies works with redfox anydvd*. it works with dvdFab too.

The dvds like bluray disks mounts virtual clone drive and brings it up in powerdvd. I have powerdvd 16[/quote]
I'm a bit confused on this one. I didn't realize that Virtual CloneDrive could mount folders. Or is there something extra going on here, like perhaps My Movies wrapping a folder as a ISO for VCD to mount?

I really don't know how this works. WMC does the magic some how. Maybe you could get powerdvd to do it on its own. or iterate over the folders and have powerdvd load the VOB or ISO file. I know that would work with powerdvd 16. Maybe someone else could supply the answers.


1) When you first start MM Browser, you will be presented with just the Gear (settings icon) and the X (exit icon). The Gear is the menu for which you are looking.

okay I got into the menu. I will try to play with that tomorrow.

* Installing and/or using AnyDVD is illegal in some countries. Users are themselves responsible for complying with local law when installing and using AnyDVD.

jkwaterman
Posted: Monday, November 06, 2017 10:21:13 PM
Groups: Member

Joined: 2/25/2010
Posts: 178

Rank:
Rank based on contribution points and purchased points. Click to see details. (2726)
Maybe you should create a new topic instead of using this thread so more people will notice it.
pauven
Posted: Monday, November 06, 2017 10:27:44 PM
Groups: Member

Joined: 5/13/2009
Posts: 114
Location: Georgia, USA

Rank:
Rank based on contribution points and purchased points. Click to see details. (76)
jkwaterman wrote:
Maybe you should create a new topic instead of using this thread so more people will notice it.


Good idea.

I was able to create a Video_TS folder, and it shows up as an online folder in My Movies.

I tried for a while to mount it with VCD, but no dice. Finally I tried playing the folder directly in PowerDVD, and it played!

So apparently you don't have to mount DVD folders, simply play them directly.

I don't anticipate any problems adding support for DVD folders, though it will probably take me a few days.

Paul

MM Browser is now Chameleon MediaCenter v2.2 - Finally for My Movies, a MCE replacement for Windows 10, plus a Music Library!
pauven
Posted: Monday, November 06, 2017 10:58:46 PM
Groups: Member

Joined: 5/13/2009
Posts: 114
Location: Georgia, USA

Rank:
Rank based on contribution points and purchased points. Click to see details. (76)
Quick Note: After adding a DVD folder, and running a Sync, now MM Browser is crashing on every start.

Sorry for the problems - didn't realize it would behave this poorly with non-ISO's - working on a solution now.

Paul

MM Browser is now Chameleon MediaCenter v2.2 - Finally for My Movies, a MCE replacement for Windows 10, plus a Music Library!
pauven
Posted: Tuesday, November 07, 2017 2:32:38 AM
Groups: Member

Joined: 5/13/2009
Posts: 114
Location: Georgia, USA

Rank:
Rank based on contribution points and purchased points. Click to see details. (76)
I have just released MM Browser v1.2, which adds support for DVD Folders.

If you are allowing MM Browser to "phone home" to check for updates, it will find the v1.2 update, show the change log, and allow you to auto-update.

Note: I have recently discovered that the auto-update does not complete successfully on Windows 7 (unable to extract the update files from the downloaded zip file). Not sure how it behaves on Windows 8/8.1, as I don't have any PC's on that platform. For now, if you are on Windows 7, you will need to manually finish the update by extracting the files from the zip file in the program directory.

Lastly, I have created a new thread for MM Browser: http://www.mymovies.dk/forum.aspx?g=posts&m=210647&#210647

Paul

MM Browser is now Chameleon MediaCenter v2.2 - Finally for My Movies, a MCE replacement for Windows 10, plus a Music Library!
jkwaterman
Posted: Tuesday, November 07, 2017 3:52:40 AM
Groups: Member

Joined: 2/25/2010
Posts: 178

Rank:
Rank based on contribution points and purchased points. Click to see details. (2726)
pauven wrote:
I have just released MM Browser v1.2, which adds support for DVD Folders.

If you are allowing MM Browser to "phone home" to check for updates, it will find the v1.2 update, show the change log, and allow you to auto-update.

Note: I have recently discovered that the auto-update does not complete successfully on Windows 7 (unable to extract the update files from the downloaded zip file). Not sure how it behaves on Windows 8/8.1, as I don't have any PC's on that platform. For now, if you are on Windows 7, you will need to manually finish the update by extracting the files from the zip file in the program directory.

Lastly, I have created a new thread for MM Browser: http://www.mymovies.dk/forum.aspx?g=posts&m=210647&#210647

Paul


I added the mymovies folder from 1 of my NAS. The icons for both blurays and dvds display in mmbrowser. The dvds come up in powerdvd 16 and play properly. For my blurays I get an error that the ISO is missing. I am using the folder location that mymovies setup when I ripped the blurays into my movies. I think you will have to have mymovies rip a bluray. It should by default create an ISO, or choose ISO for a bluray. Go into the disk in mymovies on the added bluray and you should see that the location is a folder and not a file. You will see the created ISO inside the folder through windows explorer.

If that is fixed you will be looking pretty good.
pauven
Posted: Tuesday, November 07, 2017 4:20:06 AM
Groups: Member

Joined: 5/13/2009
Posts: 114
Location: Georgia, USA

Rank:
Rank based on contribution points and purchased points. Click to see details. (76)
jkwaterman wrote:

I added the mymovies folder from 1 of my NAS. The icons for both blurays and dvds display in mmbrowser. The dvds come up in powerdvd 16 and play properly. For my blurays I get an error that the ISO is missing. I am using the folder location that mymovies setup when I ripped the blurays into my movies. I think you will have to have mymovies rip a bluray. It should by default create an ISO, or choose ISO for a bluray. Go into the disk in mymovies on the added bluray and you should see that the location is a folder and not a file. You will see the created ISO inside the folder through windows explorer.

If that is fixed you will be looking pretty good.


At the moment I don't have My Movies ripping working, sorry, so I can't test myself.

Here is the folder structure that MM Browser is expecting:

Monitored Folder\
-->Movie Folder\
---->>mymovies.xml
---->>Movie.iso

-->Movie Folder\
---->>mymovies.xml
---->>Movie.iso

-->Movie Folder\
---->>mymovies.xml
---->>Movie.iso

-->Group Folder\
---->Movie Folder\
------>>mymovies.xml
------>>Movie.iso

---->Movie Folder\
------>>mymovies.xml
------>>Movie.iso

The important bit is that the mymovies.xml is in the same folder with the .iso file.

What is the folder structure you have? Is the Blueray.iso and mymovies.xml in the same folder?

Thanks,
Paul

MM Browser is now Chameleon MediaCenter v2.2 - Finally for My Movies, a MCE replacement for Windows 10, plus a Music Library!
jkwaterman
Posted: Tuesday, November 07, 2017 4:33:46 AM
Groups: Member

Joined: 2/25/2010
Posts: 178

Rank:
Rank based on contribution points and purchased points. Click to see details. (2726)
pauven wrote:
jkwaterman wrote:

I added the mymovies folder from 1 of my NAS. The icons for both blurays and dvds display in mmbrowser. The dvds come up in powerdvd 16 and play properly. For my blurays I get an error that the ISO is missing. I am using the folder location that mymovies setup when I ripped the blurays into my movies. I think you will have to have mymovies rip a bluray. It should by default create an ISO, or choose ISO for a bluray. Go into the disk in mymovies on the added bluray and you should see that the location is a folder and not a file. You will see the created ISO inside the folder through windows explorer.

If that is fixed you will be looking pretty good.


At the moment I don't have My Movies ripping working, sorry, so I can't test myself.

Here is the folder structure that MM Browser is expecting:

Monitored Folder\
-->Movie Folder\
---->>mymovies.xml
---->>Movie.iso

-->Movie Folder\
---->>mymovies.xml
---->>Movie.iso

-->Movie Folder\
---->>mymovies.xml
---->>Movie.iso

-->Group Folder\
---->Movie Folder\
------>>mymovies.xml
------>>Movie.iso

---->Movie Folder\
------>>mymovies.xml
------>>Movie.iso

The important bit is that the mymovies.xml is in the same folder with the .iso file.

What is the folder structure you have? Is the Blueray.iso and mymovies.xml in the same folder?

Thanks,
Paul


I think the structure is the same \\DROBO_X\X_Drive\MyMovies\1 9 4 1

MyMovies is the monitored folder

1941 has the iso and xml.

For the location in computer management disc do you have the location (online) folder, or (online) file? I have online folder which is what mymovies assigned to it when it was ripped. The same as dvds. Just for bluray mymovies ripper placed the iso inside that folder.
pauven
Posted: Tuesday, November 07, 2017 4:57:04 AM
Groups: Member

Joined: 5/13/2009
Posts: 114
Location: Georgia, USA

Rank:
Rank based on contribution points and purchased points. Click to see details. (76)
jkwaterman wrote:
I think the structure is the same \\DROBO_X\X_Drive\MyMovies\1 9 4 1

MyMovies is the monitored folder

1941 has the iso and xml.

For the location in computer management disc do you have the location (online) folder, or (online) file? I have online folder which is what mymovies assigned to it when it was ripped. The same as dvds. Just for bluray mymovies ripper placed the iso inside that folder.


By any chance, is there also a VIDEO_TS folder inside the 1941 folder?

Did you run a new Sync after upgrading to MM Browser 1.2?

All of my ISOs are 'online file', but that shouldn't affect anything, as I don't do anything with that info in MM Browser. Rather, I scan all the subdirectories for the folders you list to scan, looking for mymovies.xml and *.iso (and now VIDEO_TS). I ignore what the mymovies.xml files says about the .iso and online folder/online file.

If I find a *.iso without a mymovies.xml, I still include it in the results, and just use the folder name for the movie title, and blank cover artwork.

If I find a mymovies.xml without either a VIDEO_TS or a *.iso in the same folder, then that's when I would flag the missing ISO error.

You can also open the MMBrowserDB.xml file that get's created (assuming you've turned on the Local DB option to create it). Open it in IE or Edge, and it will format it for easier reading. Then find a problem Blu-ray (like 1941), and find the tags <ISOs> and <DVDFolder>. If DVDFolder is False, then ISOs should have some full paths to ISO files listed.

Paul

MM Browser is now Chameleon MediaCenter v2.2 - Finally for My Movies, a MCE replacement for Windows 10, plus a Music Library!
jkwaterman
Posted: Tuesday, November 07, 2017 5:33:47 AM
Groups: Member

Joined: 2/25/2010
Posts: 178

Rank:
Rank based on contribution points and purchased points. Click to see details. (2726)


No folder under 1941. Just the iso and the xml plus covers and other metadata

I saved to a local database xml and noticed that one disks list the iso and the others don't in the database xml. Could a bug for isos been created when you added dvd folders or could this be related to the 100 disk limit and if so could the iso be assigned to the first 100 disks in the xml file so that I can find which disk to test. This would be only for testing purposes until people buy the license. I am interested and this seems to be the app I'm looking for.

Paul[/quote]
jkwaterman
Posted: Tuesday, November 07, 2017 6:01:48 AM
Groups: Member

Joined: 2/25/2010
Posts: 178

Rank:
Rank based on contribution points and purchased points. Click to see details. (2726)
an error log contains these errors. The duplicates are not duplicates but one number in mymovies computer management with multiple disks listed in one disk listing. Box set??

Could not find "mymovies.xml" in Folder "\\DROBO_X\X_Drive\MyMovies\Apocalypse 3 - Tribulation\AUDIO_TS"
Could not find "mymovies.xml" in Folder "\\DROBO_X\X_Drive\MyMovies\The Iron Giant"
Could not find "mymovies.xml" in Folder "\\DROBO_X\X_Drive\MyMovies\The Secret Life Of Pets"


[ERROR] The following Collection Numbers are used by more than 1 title in the My Movies database. Duplicate #'s can cause issues with the Local Art Cache. You should correct these issues in My Movies:
* 1543
* 926
* 926
* 926
* 1567
* 926
* 1543
* 926
* 1434
pauven
Posted: Tuesday, November 07, 2017 2:44:06 PM
Groups: Member

Joined: 5/13/2009
Posts: 114
Location: Georgia, USA

Rank:
Rank based on contribution points and purchased points. Click to see details. (76)
jkwaterman wrote:
No folder under 1941. Just the iso and the xml plus covers and other metadata

I saved to a local database xml and noticed that one disks list the iso and the others don't in the database xml. Could a bug for isos been created when you added dvd folders or could this be related to the 100 disk limit and if so could the iso be assigned to the first 100 disks in the xml file so that I can find which disk to test. This would be only for testing purposes until people buy the license. I am interested and this seems to be the app I'm looking for.

Okay, folder structure sounds good. This is definitely not a limitation of the 101 title limit for the free version, as each title should work 100%, you just won't ever see more than 101 titles without a license.

I think this is just a silly bug.

For the one disc that lists the ISO file(s), is the extension ".iso" <--lowercase?

For the discs that are missing the ISO file(s), are the extensions ".ISO" or ".Iso" or anything other than all lowercase ".iso"?


jkwaterman wrote:
an error log contains these errors. The duplicates are not duplicates but one number in mymovies computer management with multiple disks listed in one disk listing. Box set??

Could not find "mymovies.xml" in Folder "\\DROBO_X\X_Drive\MyMovies\Apocalypse 3 - Tribulation\AUDIO_TS"
Could not find "mymovies.xml" in Folder "\\DROBO_X\X_Drive\MyMovies\The Iron Giant"
Could not find "mymovies.xml" in Folder "\\DROBO_X\X_Drive\MyMovies\The Secret Life Of Pets"


For 'The Iron Giant' and 'The Secret Life of Pets', is MM Browser correct that those two folders have an ISO file but no mymovies.xml file? Are these perhaps new movies that My Movies hasn't processed?

For 'Apocalypse 3 - Tribulation', why is there an AUDIO_TS folder? This is just a regular movie, right? I assume that there is a VIDEO_TS folder in the same parent directory, and no .ISO, right?

jkwaterman wrote:
[ERROR] The following Collection Numbers are used by more than 1 title in the My Movies database. Duplicate #'s can cause issues with the Local Art Cache. You should correct these issues in My Movies:
* 1543
* 926
* 926
* 926
* 1567
* 926
* 1543
* 926
* 1434


So I don't have any box sets entered into my system, though I do have a few on the shelf. Guess I need to add some. If these truly are box sets, then the Art Cache issue may not be a problem, since some box sets share cover art of the parent. You should look for these titles in the GUI and see if the artwork is correct or wrong for all titles.

It would also be helpful if you could do the following:

1) Open the MMBrowserDB.xml database file in IE/Edge again.
2) Search for <ColNum>926</ColNum> which should be in the file about 6 times based upon the error log above (CTRL-F opens the search box)
3) For each of those, look at the <SBSPar> and <SBSKid> tags and see if they are True/False (SBSPar = Series Box Set Parent, SBSKid = Series Box Set Child)
4) Also, for each of those, check what movie/show they are - are they all the same box set?
5) If the titles above were Children, see if the Parent was found in the file by searching for <SBSPar>True</SBSPar>.

Okay, one last question - how 'should' a box set display in the MM Browser GUI? Should it be 1 cover for the parent, or 1 cover for each child?

Thanks,
Paul

MM Browser is now Chameleon MediaCenter v2.2 - Finally for My Movies, a MCE replacement for Windows 10, plus a Music Library!
jkwaterman
Posted: Tuesday, November 07, 2017 5:43:44 PM
Groups: Member

Joined: 2/25/2010
Posts: 178

Rank:
Rank based on contribution points and purchased points. Click to see details. (2726)
pauven wrote:
[quote=jkwaterman]No folder under 1941. Just the iso and the xml plus covers and other metadata

I saved to a local database xml and noticed that one disks list the iso and the others don't in the database xml. Could a bug for isos been created when you added dvd folders or could this be related to the 100 disk limit and if so could the iso be assigned to the first 100 disks in the xml file so that I can find which disk to test. This would be only for testing purposes until people buy the license. I am interested and this seems to be the app I'm looking for.

Okay, folder structure sounds good. This is definitely not a limitation of the 101 title limit for the free version, as each title should work 100%, you just won't ever see more than 101 titles without a license.

I think this is just a silly bug.

For the one disc that lists the ISO file(s), is the extension ".iso" <--lowercase?

For the discs that are missing the ISO file(s), are the extensions ".ISO" or ".Iso" or anything other than all lowercase ".iso"?


yes, the ones not working are uppercase ISO. The one working is a lower case iso.
jkwaterman
Posted: Tuesday, November 07, 2017 5:52:03 PM
Groups: Member

Joined: 2/25/2010
Posts: 178

Rank:
Rank based on contribution points and purchased points. Click to see details. (2726)
jkwaterman wrote:
an error log contains these errors. The duplicates are not duplicates but one number in mymovies computer management with multiple disks listed in one disk listing. Box set??

Could not find "mymovies.xml" in Folder "\\DROBO_X\X_Drive\MyMovies\Apocalypse 3 - Tribulation\AUDIO_TS"
Could not find "mymovies.xml" in Folder "\\DROBO_X\X_Drive\MyMovies\The Iron Giant"
Could not find "mymovies.xml" in Folder "\\DROBO_X\X_Drive\MyMovies\The Secret Life Of Pets"


For 'The Iron Giant' and 'The Secret Life of Pets', is MM Browser correct that those two folders have an ISO file but no mymovies.xml file? Are these perhaps new movies that My Movies hasn't processed?

the log is correct there are no xml or any other metadata file for Iron Giant and secret life of pets

For 'Apocalypse 3 - Tribulation', why is there an AUDIO_TS folder? This is just a regular movie, right? I assume that there is a VIDEO_TS folder in the same parent directory, and no .ISO, right?

There is a VIDEO_TS folder as well as AUDIO_TS. I may have used a different program like clonedvd to rip this. All the others are just VIDEO_TS

jkwaterman wrote:
[ERROR] The following Collection Numbers are used by more than 1 title in the My Movies database. Duplicate #'s can cause issues with the Local Art Cache. You should correct these issues in My Movies:
* 1543
* 926
* 926
* 926
* 1567
* 926
* 1543
* 926
* 1434


So I don't have any box sets entered into my system, though I do have a few on the shelf. Guess I need to add some. If these truly are box sets, then the Art Cache issue may not be a problem, since some box sets share cover art of the parent. You should look for these titles in the GUI and see if the artwork is correct or wrong for all titles.

It would also be helpful if you could do the following:

1) Open the MMBrowserDB.xml database file in IE/Edge again.
2) Search for <ColNum>926</ColNum> which should be in the file about 6 times based upon the error log above (CTRL-F opens the search box)
3) For each of those, look at the <SBSPar> and <SBSKid> tags and see if they are True/False (SBSPar = Series Box Set Parent, SBSKid = Series Box Set Child)
4) Also, for each of those, check what movie/show they are - are they all the same box set?
5) If the titles above were Children, see if the Parent was found in the file by searching for <SBSPar>True</SBSPar>.

Okay, one last question - how 'should' a box set display in the MM Browser GUI? Should it be 1 cover for the parent, or 1 cover for each child?

I don't know if this is truely a boxset. It is one disk entry in collection management displaying multiple disks associated that disk under disks.

Universal Classic Horror 30 film collection
Dracula - Folder for Dracula
Son of Dracula - Folder for Son of Dracula
Frankenstein - Folder for Frankenstein
Ghost of Frankensten - Folder for Ghost of Frankenstein
......
.......
.......

IN mmBrowser When you click play on the disk then it should display a list of all the the iso's related to that disk and you click on your iso,movie you want to play and powerdvd plays it.


Thanks,
Paul[/quote]
jkwaterman
Posted: Tuesday, November 07, 2017 6:17:05 PM
Groups: Member

Joined: 2/25/2010
Posts: 178

Rank:
Rank based on contribution points and purchased points. Click to see details. (2726)


jkwaterman wrote:
[ERROR] The following Collection Numbers are used by more than 1 title in the My Movies database. Duplicate #'s can cause issues with the Local Art Cache. You should correct these issues in My Movies:
* 1543
* 926
* 926
* 926
* 1567
* 926
* 1543
* 926
* 1434


So I don't have any box sets entered into my system, though I do have a few on the shelf. Guess I need to add some. If these truly are box sets, then the Art Cache issue may not be a problem, since some box sets share cover art of the parent. You should look for these titles in the GUI and see if the artwork is correct or wrong for all titles.

It would also be helpful if you could do the following:

1) Open the MMBrowserDB.xml database file in IE/Edge again.
2) Search for <ColNum>926</ColNum> which should be in the file about 6 times based upon the error log above (CTRL-F opens the search box)
3) For each of those, look at the <SBSPar> and <SBSKid> tags and see if they are True/False (SBSPar = Series Box Set Parent, SBSKid = Series Box Set Child)

sbsPar and SBSKid are false for all. This a dvd title by the way

-<Title>

<Name>Little House On The Prairie - [Season 8 Disc 2 Episodes 04-07]</Name>

<Sort>Little House On The Prairie - [Season 8 Disc 2 Episodes 04-07]</Sort>

<Dir>\\DROBO_X\X_Drive\MyMovies\Little House on the Prairie- The Complete Television Series - Season 8 - Disk 2</Dir>

<XML>\\DROBO_X\X_Drive\MyMovies\Little House on the Prairie- The Complete Television Series - Season 8 - Disk 2\mymovies.xml</XML>

<ColNum>926</ColNum>

<Media/>

<Lent>False</Lent>

<Online>True</Online>

<SBSPar>False</SBSPar>

<SBSKid>False</SBSKid>

<Ed>55-Disc Set</Ed>

<AspRat>1.33:1</AspRat>

<VidStd>NTSC</VidStd>

<AudioTracks/>

<Subtitles/>

<ISOs/>

<DVDFolder>True</DVDFolder>

<DT>dtDVD</DT>

<ImgFol>folder.jpg</ImgFol>

second entry

-<Title>

<Name>Little House On The Prairie - [Season 9 Disc 3 Episodes 07-10 SF]</Name>

<Sort>Little House On The Prairie - [Season 9 Disc 3 Episodes 07-10 SF]</Sort>

<Dir>\\DROBO_X\X_Drive\MyMovies\Little House on the Prairie- The Complete Television Series - Season 9 - Disk 3</Dir>

<XML>\\DROBO_X\X_Drive\MyMovies\Little House on the Prairie- The Complete Television Series - Season 9 - Disk 3\mymovies.xml</XML>

<ColNum>926</ColNum>

<Media/>

<Lent>False</Lent>

<Online>True</Online>

<SBSPar>False</SBSPar>

<SBSKid>False</SBSKid>

<Ed>55-Disc Set</Ed>

<AspRat>1.33:1</AspRat>

<VidStd>NTSC</VidStd>

<AudioTracks/>

<Subtitles/>

<ISOs/>

<DVDFolder>True</DVDFolder>
4) Also, for each of those, check what movie/show they are - are they all the same box set?
5) If the titles above were Children, see if the Parent was found in the file by searching for <SBSPar>True</SBSPar>.

Okay, one last question - how 'should' a box set display in the MM Browser GUI? Should it be 1 cover for the parent, or 1 cover for each child?

Thanks,
Paul[/quote]
Users browsing this topic
guest


Forum Jump
You cannot post new topics in this forum.
You cannot reply to topics in this forum.
You cannot delete your posts in this forum.
You cannot edit your posts in this forum.
You cannot create polls in this forum.
You cannot vote in polls in this forum.

Main Forum RSS : RSS

Powered by Yet Another Forum.net version 1.9.0 (NET v4.0) - 10/10/2006
Copyright © 2003-2006 Yet Another Forum.net. All rights reserved.