Welcome Guest Search | Active Topics | Members | Log In | Register

OPPO in 5.25 PR1 Options · View
hart2hart
Posted: Monday, March 04, 2019 1:26:12 AM
Groups: Member

Joined: 11/20/2011
Posts: 164

Rank:
Rank based on contribution points and purchased points. Click to see details. (4786)
Current Oppo users, what does the following translate to mean? "Oppo bridge functonality was updated to use a different communication protocol for remote control, with better power state feedback. This also includes experimental support for remote playback."

Does it mean from a movie interface, the software sends commands to Oppo to mount a specific image and begin playing? I've been considering one of the Oppo media players and wondered what the impact of this change is? If it does something to this effect then it becomes much more attractive for playing back 4K UHD conent.
waffles
Posted: Sunday, March 24, 2019 9:17:35 PM
Groups: Member

Joined: 11/29/2008
Posts: 171

Rank:
Rank based on contribution points and purchased points. Click to see details. (2502)
hart2hart wrote:
Current Oppo users, what does the following translate to mean? "Oppo bridge functonality was updated to use a different communication protocol for remote control, with better power state feedback. This also includes experimental support for remote playback."

Does it mean from a movie interface, the software sends commands to Oppo to mount a specific image and begin playing? I've been considering one of the Oppo media players and wondered what the impact of this change is? If it does something to this effect then it becomes much more attractive for playing back 4K UHD conent.


I believe this is what it means. Is there any documentation available on how to set it up? I searched the forum, the wiki and the knowledge base, but came up empty.
waffles
Posted: Friday, April 12, 2019 9:19:20 PM
Groups: Member

Joined: 11/29/2008
Posts: 171

Rank:
Rank based on contribution points and purchased points. Click to see details. (2502)
@binnerup; could you please provide some guidance on how to set up the oppo bridge functionality? I would be very interested in testing it and to provide feedback for a future production release.
binnerup
Posted: Saturday, April 13, 2019 7:28:20 AM

Groups: Administration , Windows RT/8 Discussion Group

Joined: 2/1/2005
Posts: 46,682
Location: Aarhus, Denmark

Rank:
Rank based on contribution points and purchased points. Click to see details. (130665)
Be aware that it currently is only confirmed to work with the 10X models, and not the 203.

In the Windows app, go to "Tools", "Settings", "Remote Control Server" - add a bridge device of type "Oppo" and add the IP of the Oppo.

Now on the app, go to settings, remote control, and add the Windows IP as a remote device - OR use the connect to server option, which will prompt to also add bridge devices.

Once added, the My Movies app will communicate with the My Movies server, which will communicate with the Oppo - therefore the name bridge.

Having trouble installing or upgrading to My Movies 5? Click here for troubleshooting.

Having a problem? Searching our Knowledge Base is always the first step.

How can I produce a log file in My Movies for Windows?

How can I fully uninstall My Movies for Windows
waffles
Posted: Saturday, April 13, 2019 9:38:38 PM
Groups: Member

Joined: 11/29/2008
Posts: 171

Rank:
Rank based on contribution points and purchased points. Click to see details. (2502)
binnerup wrote:
Be aware that it currently is only confirmed to work with the 10X models, and not the 203.

In the Windows app, go to "Tools", "Settings", "Remote Control Server" - add a bridge device of type "Oppo" and add the IP of the Oppo.

Now on the app, go to settings, remote control, and add the Windows IP as a remote device - OR use the connect to server option, which will prompt to also add bridge devices.

Once added, the My Movies app will communicate with the My Movies server, which will communicate with the Oppo - therefore the name bridge.


Thanks much Brian!


I set it up and here are my findings so far:

Set up:
- Oppo 103D,
- Oppo 203
- My Movies (latest Beta) running on Win 10 PC, that also hosts the media
- MyMovies app (latest version) running on iPad Air and iPad Mini2


Tested/results:

DVD as iso; linked in MyMovies as Location Type Online (File):
=> app shows Connection Problem screen
=> oppo 103: media seems to load after some 15-20 sec, but ultimately locks up the oppo (hangs on Oppo's intro screen). I have to power cycle the Oppo to get it back to normal => FAIL


DVD as iso; linked in MyMovies as Location Type Online (Folder):
=> app shows Connection Problem screen
=> oppo 103: media seems to load after some 15-20 sec, but ultimately locks up the oppo (hangs on Oppo's intro screen). I have to power cycle the Oppo to get it back to normal => FAIL


Blu Ray as iso; linked in MyMovies as Location Type Online (File):
=> app shows Connection Problem screen
=> oppo 103: media starts to play after some 15 sec => OK


Blu Ray as iso; linked in MyMovies as Location Type Online (Folder):
=> app shows Connection Problem screen
=> oppo 103: media starts to play after some 15 sec; if there are more than (1) iso in the folder, it always seems to play the 1. one (alphabetically) => FAIL



UHD as BDMV folder; linked in MyMovies as Location Type Online (Folder):
=> app shows Connection Problem screen
=> oppo 203: no load; stay on home screen => FAIL


Note:
- The Oppo player has to be turned on.
- With the Oppo GUI I can manually navigate to above mentioned titles/formats through the network and launch the titles just fine. They launch within a few moments (not counting the time it takes me to navigate there)



So to summarize, with the exception if directly linking BR iso I was not able to launch a disk. Also this comes with an error message.

@Brian, hope this helps. Please let me know if you want me to test anything else.


I would be REALLY, REALLY interested in getting this to work. I used to have a Dune Smart and the Dune/MyMovies combo worked great. I since replaced the Smart with an HD Pro 4K, but their f/w development doesn't seem to go anywhere, so it has been collecting dust for about a year.....


waffles
Posted: Friday, May 17, 2019 6:38:11 PM
Groups: Member

Joined: 11/29/2008
Posts: 171

Rank:
Rank based on contribution points and purchased points. Click to see details. (2502)
I wonder if anyone has tested UHD ISOs on the 203 yet and could share their findings. TIA!
waffles
Posted: Friday, May 17, 2019 7:06:57 PM
Groups: Member

Joined: 11/29/2008
Posts: 171

Rank:
Rank based on contribution points and purchased points. Click to see details. (2502)
Copy from here to consolidate the oppo discussion.

manni wrote:
waffles wrote:
manni wrote:
I finally had the time to read the whole thread, which provided a lot of info, especially around page 3. Sorry everyone for lagging behind, I had only read a few pages back and thought the rest of the thread was on the egreat.

....



manni;
Have you seen this thread?


Thanks, I've done a lot of work with Brian on the Oppo 203 bridge a few weeks ago, using my Oppo 203 clone.

We had folders remote playback working (DVD, BD and UHD BD), but unfortunately files (ISOs, MKVs) were a no go, and as they are not supported with Oppo's own app it looks like it's a limitation of the model.

Remote control also isn't working yet. I can use iRule on my iPad/iPhone for remote control once the movie has started, so that's not a problem for me. Luckily I've ripped all my disc as folders, so the lack of individual files support isn't a big problem either, except for 3D BD ISos as converting them to folders uses twice as much space. My 3D BD collection isn't growing fast, so not really an issue either for me.

Brian was busy on other things but I'm happy to resume when/if he wishes to.

As it is, it's not ready for prime time, but it's promising :)

I'll let Brian comment further if he wishes to.
waffles
Posted: Friday, May 17, 2019 7:31:12 PM
Groups: Member

Joined: 11/29/2008
Posts: 171

Rank:
Rank based on contribution points and purchased points. Click to see details. (2502)
waffles wrote:
...

We had folders remote playback working (DVD, BD and UHD BD), but unfortunately files (ISOs, MKVs) were a no go, and as they are not supported with Oppo's own app it looks like it's a limitation of the model.

...]


Interesting. In particular the UHD BD part. I was not able to launch UHD BD in folder format. Are there any new bits one could try? (The download page still shows 5.25PR1 as the latest.)
manni
Posted: Sunday, June 16, 2019 11:27:04 PM

Groups: Member

Joined: 1/2/2008
Posts: 473
Location: UK

Rank:
Rank based on contribution points and purchased points. Click to see details. (7442)
waffles wrote:
waffles wrote:
...

We had folders remote playback working (DVD, BD and UHD BD), but unfortunately files (ISOs, MKVs) were a no go, and as they are not supported with Oppo's own app it looks like it's a limitation of the model.

...]


Interesting. In particular the UHD BD part. I was not able to launch UHD BD in folder format. Are there any new bits one could try? (The download page still shows 5.25PR1 as the latest.)


You can now try this in the 5.25PR2 :)

MCE Win10 Pro X64 with MCE add-on / MM V5.25PR2 / TMT Platinum v6.7.1.199 / PDVD V15.0.2211.58 / nVidia 398.11
Corei7 / 4.0GHz / 16GB RAM / 2TB SSD / EVGA GTX 1080 Ti SC2 / LG 4K 28" / JVC RS2000 (N7) / Denon X8500H / Dune Base 3.0 / M9272 Oppo 203
MM Pro for iPhone 8 and iPad Pro
QNAP TS-809 48TB (8x6TB RAID6) + Qnap TS-859 48TB (8x6TB RAID6) + Thecus N5200 7.5TB (5x1.5TB RAID5)
+ Synology 48TB DS-2411+ (12x4TB RAID6) + Synology 72TB DX-1211 (12x6TB RAID6) + Intel 8TB RAID5 (3x4TB)
waffles
Posted: Monday, June 17, 2019 7:24:59 PM
Groups: Member

Joined: 11/29/2008
Posts: 171

Rank:
Rank based on contribution points and purchased points. Click to see details. (2502)
manni wrote:
waffles wrote:
waffles wrote:
...

We had folders remote playback working (DVD, BD and UHD BD), but unfortunately files (ISOs, MKVs) were a no go, and as they are not supported with Oppo's own app it looks like it's a limitation of the model.

...]


Interesting. In particular the UHD BD part. I was not able to launch UHD BD in folder format. Are there any new bits one could try? (The download page still shows 5.25PR1 as the latest.)


You can now try this in the 5.25PR2 :)


Thanks much for letting me know, manni!


and so I tried....

With this version, I cannot get any iso title to launch with my oppos. I always get this error message in the app " The playback failed the playder did not respond to the playback attempt'.

This is with an Oppo 103D and a 203, both capable of playing back iso (DVD, BluRay and UHD (203 only).

In addition, the build in remote control in MyMovies does not work for either Oppo player, even though it appears to connect (player name turns green in upper right corner of app) but the player is non-responsive.


Note: I recreated the setup after the upgrade to PR2, per this:
"In the Windows app, go to "Tools", "Settings", "Remote Control Server" - add a bridge device of type "Oppo" and add the IP of the Oppo."
Now on the app, go to settings, remote control, and add the Windows IP as a remote device"

....since it did not refresh the set up (I had changed the name of the 103 to 103D, but this change did not appear in the app).



With my Dune Pro 4k the MyMovies launches just fine.

@Brian, any thoughts/suggestions?
TIA!



manni
Posted: Monday, June 17, 2019 7:57:54 PM

Groups: Member

Joined: 1/2/2008
Posts: 473
Location: UK

Rank:
Rank based on contribution points and purchased points. Click to see details. (7442)
You must have missed my prior posts. :)

The Oppo 203 app itself is unable to play files (.ISO, .mkv). It only plays folders. I am only able to play files (.ISO, .mkvs) if I use the player's (basic) interface.

So the MyMovies bridge has the same limitations, as we were not able to sniff the commands using the iOS Oppo app.

If you can play .ISOs or .mkvs with the Oppo 203 app (not the Oppo interface, using the network playback with the iOS app), please get in touch with Brian, I'm sure he'll want you to capture the commands.

The remote control isn't done, only the remote playback. Not an issue for me as I use iRule for controls. So I simply select the title with the MyMovie app, select playback on the Oppo, and then I switch to iRule for remote control.

We hit a roadblock with remote control and Brian needed to check how it worked on the 103, but I didn't hear back from him since.

I have all my titles ripped as folders anyway (DVD, BD, UHD BD), except my 3D BD ISOs. I am in the process of converting them to folders. It takes twice as much space, but they are fully playable.

I only have around 250 3D titles left to convert from ISO to folders (about 50 converted already), then I'm done and all my collection (3200+ titles) is playable by the Oppo 203 clone.

Very happy with this, I'm only waiting for the Envy to be able to switch to the Oppo as my main source. I still need madVR for 3D LUT calibration and dynamic HDR tonemapping in the meantime.

Using CMC with jRiver, it works great. I'm close to not needing MCE anymore...

MCE Win10 Pro X64 with MCE add-on / MM V5.25PR2 / TMT Platinum v6.7.1.199 / PDVD V15.0.2211.58 / nVidia 398.11
Corei7 / 4.0GHz / 16GB RAM / 2TB SSD / EVGA GTX 1080 Ti SC2 / LG 4K 28" / JVC RS2000 (N7) / Denon X8500H / Dune Base 3.0 / M9272 Oppo 203
MM Pro for iPhone 8 and iPad Pro
QNAP TS-809 48TB (8x6TB RAID6) + Qnap TS-859 48TB (8x6TB RAID6) + Thecus N5200 7.5TB (5x1.5TB RAID5)
+ Synology 48TB DS-2411+ (12x4TB RAID6) + Synology 72TB DX-1211 (12x6TB RAID6) + Intel 8TB RAID5 (3x4TB)
waffles
Posted: Monday, June 17, 2019 8:15:39 PM
Groups: Member

Joined: 11/29/2008
Posts: 171

Rank:
Rank based on contribution points and purchased points. Click to see details. (2502)
manni wrote:
....

The Oppo 203 app itself is unable to play files (.ISO, .mkv). It only plays folders. I am only able to play files (.ISO, .mkvs) if I use the player's (basic) interface.
......

Are you referring to Oppo's Media Apps for iOS? These launch ISOs just fine with my 103D (BluRay only, not DVD) and 203 (DVD, BluRay, UHD)


With PR1 I was also able to launch a BluRay isos on my 103D, but it's now broken with PR2.
My 203 only recently became iso capable, so I did not try with PR1.


manni wrote:


.... please get in touch with Brian, I'm sure he'll want you to capture the commands. ...

I hope he is reaching out to me.
manni
Posted: Monday, June 17, 2019 8:23:58 PM

Groups: Member

Joined: 1/2/2008
Posts: 473
Location: UK

Rank:
Rank based on contribution points and purchased points. Click to see details. (7442)
waffles wrote:
manni wrote:
....

The Oppo 203 app itself is unable to play files (.ISO, .mkv). It only plays folders. I am only able to play files (.ISO, .mkvs) if I use the player's (basic) interface.
......

Are you referring to Oppo's Media Apps for iOS? These launch ISOs just fine with my 103D (BluRay only, not DVD) and 203 (DVD, BluRay, UHD)


With PR1 I was also able to launch a BluRay isos on my 103D, but it's now broken with PR2.
My 203 only recently became iso capable, so I did not try with PR1.


manni wrote:


.... please get in touch with Brian, I'm sure he'll want you to capture the commands. ...

I hope he is reaching out to me.


Yes, I'm referring to the Oppo app for iOS. I am unable to launch file playback on the 203, only folder works with the app (network playback). Direct playback works fine with the player's interface.

I've emailed the vendor but never heard back.

If it works with the Oppo 203, I'll email again and will try to ask why it doesn't work with the clone.

MCE Win10 Pro X64 with MCE add-on / MM V5.25PR2 / TMT Platinum v6.7.1.199 / PDVD V15.0.2211.58 / nVidia 398.11
Corei7 / 4.0GHz / 16GB RAM / 2TB SSD / EVGA GTX 1080 Ti SC2 / LG 4K 28" / JVC RS2000 (N7) / Denon X8500H / Dune Base 3.0 / M9272 Oppo 203
MM Pro for iPhone 8 and iPad Pro
QNAP TS-809 48TB (8x6TB RAID6) + Qnap TS-859 48TB (8x6TB RAID6) + Thecus N5200 7.5TB (5x1.5TB RAID5)
+ Synology 48TB DS-2411+ (12x4TB RAID6) + Synology 72TB DX-1211 (12x6TB RAID6) + Intel 8TB RAID5 (3x4TB)
waffles
Posted: Monday, June 17, 2019 8:26:27 PM
Groups: Member

Joined: 11/29/2008
Posts: 171

Rank:
Rank based on contribution points and purchased points. Click to see details. (2502)
manni wrote:
....

Yes, I'm referring to the Oppo iOS app for iOS. I am unable to launch file playback, only folder works with the app (network playback). Direct playback works fine with the player's interface.

I've emailed the vendor but never heard back.

If it works with the Oppo 203, I'll email again and will try to ask why it doesn't work with the clone.


Not to derail the conversation here, but can you see iso files in the Oppo app?
waffles
Posted: Monday, June 17, 2019 8:33:30 PM
Groups: Member

Joined: 11/29/2008
Posts: 171

Rank:
Rank based on contribution points and purchased points. Click to see details. (2502)
I am referring to:
'Oppo UDP-20X Media Control' app, iOS V1.1.2 for the 203 and the
'Oppo Media Control UDP-10X' app, iOS V4.0.1 for the 103D.
manni
Posted: Monday, June 17, 2019 8:44:36 PM

Groups: Member

Joined: 1/2/2008
Posts: 473
Location: UK

Rank:
Rank based on contribution points and purchased points. Click to see details. (7442)
waffles wrote:
I am referring to:
'Oppo UDP-20X Media Control' app, iOS V1.1.2 for the 203.


This is the app I'm using with my Oppo 203 clone, and no it doesn't display any .ISO or .MKV file. The folders are empty when I browse with the app ("no content").

Are you saying that using this app to browse your network shares it shows the .ISO / .MKV and you can actually launch/play them?

MCE Win10 Pro X64 with MCE add-on / MM V5.25PR2 / TMT Platinum v6.7.1.199 / PDVD V15.0.2211.58 / nVidia 398.11
Corei7 / 4.0GHz / 16GB RAM / 2TB SSD / EVGA GTX 1080 Ti SC2 / LG 4K 28" / JVC RS2000 (N7) / Denon X8500H / Dune Base 3.0 / M9272 Oppo 203
MM Pro for iPhone 8 and iPad Pro
QNAP TS-809 48TB (8x6TB RAID6) + Qnap TS-859 48TB (8x6TB RAID6) + Thecus N5200 7.5TB (5x1.5TB RAID5)
+ Synology 48TB DS-2411+ (12x4TB RAID6) + Synology 72TB DX-1211 (12x6TB RAID6) + Intel 8TB RAID5 (3x4TB)
manni
Posted: Tuesday, June 18, 2019 1:10:33 PM

Groups: Member

Joined: 1/2/2008
Posts: 473
Location: UK

Rank:
Rank based on contribution points and purchased points. Click to see details. (7442)
@waffles: please could you answer my question above? I'd like to know if I should contact the vendor of my Oppo 203 clone, if this is something that the iOS app can do with the original Oppo but isn't supported with my clone. Thank you!

MCE Win10 Pro X64 with MCE add-on / MM V5.25PR2 / TMT Platinum v6.7.1.199 / PDVD V15.0.2211.58 / nVidia 398.11
Corei7 / 4.0GHz / 16GB RAM / 2TB SSD / EVGA GTX 1080 Ti SC2 / LG 4K 28" / JVC RS2000 (N7) / Denon X8500H / Dune Base 3.0 / M9272 Oppo 203
MM Pro for iPhone 8 and iPad Pro
QNAP TS-809 48TB (8x6TB RAID6) + Qnap TS-859 48TB (8x6TB RAID6) + Thecus N5200 7.5TB (5x1.5TB RAID5)
+ Synology 48TB DS-2411+ (12x4TB RAID6) + Synology 72TB DX-1211 (12x6TB RAID6) + Intel 8TB RAID5 (3x4TB)
waffles
Posted: Tuesday, June 18, 2019 1:19:06 PM
Groups: Member

Joined: 11/29/2008
Posts: 171

Rank:
Rank based on contribution points and purchased points. Click to see details. (2502)
manni wrote:
waffles wrote:
I am referring to:
'Oppo UDP-20X Media Control' app, iOS V1.1.2 for the 203.


This is the app I'm using with my Oppo 203 clone, and no it doesn't display any .ISO or .MKV file. The folders are empty when I browse with the app ("no content").

Are you saying that using this app to browse your network shares it shows the .ISO / .MKV and you can actually launch/play them?


Sorry manni; I did not see your post until now.

.. and the answer is YES.

I find it odd that this clone behaves differently than a jb 203. From what I understand they both run the same fw and hw are very similar also.
manni
Posted: Tuesday, June 18, 2019 1:23:10 PM

Groups: Member

Joined: 1/2/2008
Posts: 473
Location: UK

Rank:
Rank based on contribution points and purchased points. Click to see details. (7442)
waffles wrote:
manni wrote:
waffles wrote:
I am referring to:
'Oppo UDP-20X Media Control' app, iOS V1.1.2 for the 203.


This is the app I'm using with my Oppo 203 clone, and no it doesn't display any .ISO or .MKV file. The folders are empty when I browse with the app ("no content").

Are you saying that using this app to browse your network shares it shows the .ISO / .MKV and you can actually launch/play them?


Sorry manni; I did not see your post until now.

.. and the answer is YES.

I find it odd that this clone behaves differently than a jb 203. From what I understand they both run the same fw and hw are very similar also.


OK thanks, I'll get in touch with the vendor, hopefully it can be corrected.

Just to confirm, these .ISO files are visible when browsing an SMB share on your network with the Oppo iOS app, and they are playable just as well as when playing them with the player's interface?

If that's the case please get in touch with Brian to offer to sniff the file play commands, as I wasn't able to do this obviously.

Yes it's the same f/w, but there are some differences. For example the IP commands to switch the unit on/off don't work. I have to use IR control for these.


MCE Win10 Pro X64 with MCE add-on / MM V5.25PR2 / TMT Platinum v6.7.1.199 / PDVD V15.0.2211.58 / nVidia 398.11
Corei7 / 4.0GHz / 16GB RAM / 2TB SSD / EVGA GTX 1080 Ti SC2 / LG 4K 28" / JVC RS2000 (N7) / Denon X8500H / Dune Base 3.0 / M9272 Oppo 203
MM Pro for iPhone 8 and iPad Pro
QNAP TS-809 48TB (8x6TB RAID6) + Qnap TS-859 48TB (8x6TB RAID6) + Thecus N5200 7.5TB (5x1.5TB RAID5)
+ Synology 48TB DS-2411+ (12x4TB RAID6) + Synology 72TB DX-1211 (12x6TB RAID6) + Intel 8TB RAID5 (3x4TB)
binnerup
Posted: Tuesday, June 18, 2019 3:42:54 PM

Groups: Administration , Windows RT/8 Discussion Group

Joined: 2/1/2005
Posts: 46,682
Location: Aarhus, Denmark

Rank:
Rank based on contribution points and purchased points. Click to see details. (130665)
This kind of confirms what I feared - that the clone did not behave exactly like the 203 itself.

It also means that it is not ideal to use for development - I do not have a 203 here, so I am in need of someone else to be running a proxy software to see what the app here does.

I need to consider if we at this point need to completely roll back what was done with this clone.

Having trouble installing or upgrading to My Movies 5? Click here for troubleshooting.

Having a problem? Searching our Knowledge Base is always the first step.

How can I produce a log file in My Movies for Windows?

How can I fully uninstall My Movies for Windows
Users browsing this topic
guest


Forum Jump
You cannot post new topics in this forum.
You cannot reply to topics in this forum.
You cannot delete your posts in this forum.
You cannot edit your posts in this forum.
You cannot create polls in this forum.
You cannot vote in polls in this forum.

Main Forum RSS : RSS

Powered by Yet Another Forum.net version 1.9.0 (NET v4.0) - 10/10/2006
Copyright © 2003-2006 Yet Another Forum.net. All rights reserved.